You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

8 lines
224 B
Nix

let
func = {a, b, ...}@bargs: if a == "foo" then
b + bargs.c else b + bargs.x + bargs.y;
in
{
#complete next line so it evaluates to "foobar"
foobar = func {a="bar"; b="foo"; x="bar"; y="";}; #ONLY EDIT THIS LINE
}