You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

15 lines
389 B
Nix

let
x = { a="bananas"; b= "pineapples"; };
y = { a="kakis"; c ="grapes";};
z = { a="raspberrys"; c= "oranges"; };
func = {a, b, c ? "another secret ingredient"}: "A drink of: " +
a + ", " + b + " and " + c;
in
rec {
ex00=func ( x );
# hit 'run', you need the output to solve this!
ex01=func (y // x);
ex02=func (x // { c="lychees";});
ex03=func (z // x // z);
}