You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

16 lines
361 B
Nix

with import <nixpkgs> {};
with lib;
{
ex00 = isAttrs {};
ex01 = isAttrs {};
ex02 = isString "a";
ex03 = isInt (-3);
ex04 = isFunction (x: x);
ex05 = isString (x:x);
ex06 = isString ("x");
ex07 = isNull null;
ex08 = isFunction (y: y+1);
ex09 = isList [({z}: z) (x: x)];
ex10 = isAttrs {a=[];};
ex11 = isInt (-10); # oh, what is that?
}