You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

9 lines
196 B
Nix

with import <nixpkgs> { };
let
attrSet = {c = 3; a = 1; b = 2;};
attrValues = s: map (field: s.${field}) (builtins.attrNames s);
in
rec {
solution = attrValues attrSet; #should be [1 2 3]
}